Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to fix " Message: Rule processing failed " in cpanel Apache

I a getting such an error in the modsecurity logs in a cpanel server. I am not able to pinpoint the issue or rule which is getting triggered and I hired a sysadmin as well and he also is unable to fix it

Do you have any idea ?
Hi Chris

Did you checked disabling the modsec rules or any of the rules ?

I had some similar issues with OWSAP Modsecrule enabled in a cpanel server and If I believe it was due to some modsec rules which needed to be registered on some honey pot site.

Let me check my old mails and will update you the exact reply as I had contacted cpanel staff on those days

Hi Chris

This is the fix which worked for me on that day .

This error is likely due to the 'REQUEST-10-IP-REPUTATION.conf' OWASP rule, which can be disabled at WHM > Security Center »ModSecurity™ Vendors » Select Vendor Rule Sets. This rule actually requires an API key from '' to fully utilize the rule.

It doesn't appear this API key has been added to your configuration. This can be added via WHM > Security Center »ModSecurity™ Configuration » Configure Global Directives > "Project Honey Pot".

Please try this and let me know if all is fine after this..

I guess that worked and that was the case. I will be monitoring the logs from now and will update this thread if there is any more such error.

Thanks a lot Techyllinux !!!!! You helped me once again..

Forum Jump:

Users browsing this thread: 1 Guest(s)